WordPress Beveiligen

WordPress beveiligenWordPress beveiligen is zeker geen onbelangrijk deel van het onderhouden van je website.

WordPress is ontzettend populair en wordt op ongeveer 23% van alle websites op internet gebruikt. Je kunt je hierdoor wel voorstellen dat WordPress erg interessant is om aanvallen op te plegen.

Hoewel niemand je kan garanderen dat je website 100% veilig is, wil je natuurlijk wel je website zo goed mogelijk zien te beveiligen.

In deze categorie staan daarom allerlei tips om ervoor te zorgen dat jij jouw WordPress website beter kunt beveiligen en minder risico loopt.

WordPress inlogpogingen limiteren

Beveiliging is een onderdeel van een website waar iedereen rekening mee zou moeten houden.

Dit is een van de redenen waarom je ook altijd een back-up van je WordPress website moet maken.

Een van de meest gebruikte aanvallen waarmee een WordPress website te maken mee krijgt is een Brute Force Attack. Dit betekent simpel gezegd dat een hacker je gebruikersnaam en wachtwoord probeert te raden tot hij het goed heeft. Bij WordPress websites wordt met name de gebruikersnaam “Admin” aangevallen.

In de meeste gevallen is dit allemaal voorgeprogrammeerd en hoeft er alleen maar een script aangezet te worden die massaal websites langsgaat en wachtwoorden probeert te raden.

Met de plugin Limit Login Attempts kun je het aantal mislukte inlogpogingen bijhouden en limiteren. Lees verder →

Verwijder inactieve plugins en themes in WordPress

Wanneer je WordPress net hebt geïnstalleerd heb je direct een aantal overbodige bestanden op je server staan die je niet meer nodig hebt.

Na verloop van tijd bestaat ook de kans dat je een aantal overbodige plugins en themes hebt waar je helemaal geen gebruik meer van gaat maken.

Je kunt al deze bestanden, plugins en themes het best verwijderen om veiligheidslekken en kwetsbaarheden te voorkomen. Lees verder →

Hou WordPress altijd up-to-date

Om je WordPress website zo veilig mogelijk te houden is de allerbelangrijkste stap altijd de meest recente versie van WordPress te gebruiken en te updaten wanneer er een nieuwe versie beschikbaar is.

Zodra er een nieuwe versie is, loopt de oude versie al snel meer gevaar voor kwaadaardige aanvallen dan dat hij deed. Dit komt omdat WordPress.org bij een nieuwe versie aangeeft wat de versie allemaal voor nieuwe dingen kan en wat er allemaal is aangepast. Deze berichten bevatten echter ook beveiligingslekken die zijn gedicht, waardoor oude versies sneller gevaar lopen. Lees verder →